Django version is no longer supported

Django version is not receiving bug fixes, and security fixes, and data-loss fixes.

Django releases are supported for a limited period of time. Some Django releases are long-term support (LTS) releases, which will get security and data loss fixes applied for typically three years.

If the Django version a project uses is no longer supported then it will be vulnerable to bugs and hacks with no path to redemptions, so it is advisable to upgrade Django to a supported version.

Are you affected? Check with
pip install django-doctor
.

Configuring this check

Django Doctor will run this check by default. No configuration is needed but the check can be turned on/off using check code django-version-support in your pyproject.toml file.

Read more about configuring Django Doctor.